Экспорт и импорт данных

Общие сведения об экспорте/импорте

Способы экспорта/импорта данных:

  • Файловый обмен в интерфейсе системы в разделах главного меню:
    • Для пользователей Агента (Клиента):
      • Раздел «Импорт» - импорт данных из файлов произвольной структуры или единичный импорт введенных значений из заполненной формы в интерфейсе
      • Раздел «Сервис» - импорт данных по шаблонам установленного образца, экспорт данных
    • Для пользователей Владельца системы и организаций-партнеров:
      • Раздел «Администрирование»
  • Сервис «Datapool» для автоматизированного обмена данными с использованием стандарта XML-RPC и PGP-шифрования

Примечание

  1. В рамках данного Руководства представлено описание работы в основном интерфейсе системы в разделах «Сервис» и «Импорт».
  2. Для подключения раздела «Импорт» отправьте заявку в Службу сопровождения
  3. Для настройки двустороннего обмена через сервис «Datapool» обратитесь в Службу сопровождения

О разделе «Импорт»

Раздел предназначен для импорта данных в систему из файлов произвольной структуры или импорта введенных значений из заполненной формы в интерфейсе.

Структура и состав вкладок в разделе «Импорт» настраивается Владельцем системы индивидуально для каждого Агента.

Структура раздела «Импорт» по типу импортируемых данных:

  • Импорт поступлений
  • Импорт старых номеров ЛС
  • Импорт регистрации
  • Импорт даты окончания льготы
  • Импорт ИПУ
  • Импорт показаний ПУ
  • Импорт поверок ПУ
  • Импорт ППИ
  • Доимпорт параметров договора с принципалом
  • Акты МСП
  • Импорт договоров поставщика с принципалом
  • Импорт внешних идентификаторов
  • Импорт договорных объемов
  • Импорт Собственниковарендаторов
  • Импорт ФЗ льготников
  • Импорт ФЗ льготников (Новосибирск)
  • Импорт ГПУ
  • Импорт спец.настроек ГПУ
  • Импорт домов
  • Доимпорт домов
  • Импорт жильцов
  • Импорт документов персоны
  • Импорт актов разовых услуг
  • Импорт тарифов
  • Импорт договоров с принципалом

См.также

Описание шагов импорта данных смотрите на текущей странице в нижеследующием разделе Импорт данных.

О разделе «Сервис»

Раздел предназначен для экспорта/импорта данных по шаблонам установленного образца из/в систему.

Структура и состав вкладок в разделе «Сервис» настраивается Владельцем системы индивидуально для каждого Агента

Структура раздела «Сервис» по типу импортируемых/экспортируемых данных:

  • Импорт поступлений
  • Импорт показаний
  • Обмен с банками
  • Экспорт в соцзащиту
  • Импорт данных из XLSX (поддерживает импорт данных в систему из файлов произвольной структуры)
  • Экспорт данных
  • Импорт внешних данных
  • Импорт ПУ
  • Импорт актов
  • Импорт сообщений в ЛС
  • Обмен данными с ГИС ЖКХ

О разделе «Администрирование»

Раздел главного меню «Администрирование» доступен в интерфейсе для пользователей Владельца системы и организаций-партнеров.

Структура раздела настраивается Владельцем системы.

Раздел содержит инструменты работы с Агентом на этапе внедрения и настройки отдельных функций системы.

Структура раздела «Администрирование» по типу настраиваемых данных:

  • Копирование услуг - копирование справочника услуг из другого Агента (раздел «Справочники» ‣ Услуги ‣ Перечень)
  • Копирование льгот - копирование справочника «Льготы» из другого Агента (раздел «Справочники» ‣ Льготы)
  • Импорт услуг на ЛС - импорт услуг, назначенных на ЛС Агента из файла
  • Импорт весов на услуги - импорт параметра «Вес» на услуги лицевых счетов
  • Импорт домов - импорт новых домов
  • Импорт счетов - импорт новых ЛС
  • Доимпорт параметров дома - обновление параметров домов: перезапись или изменение с заданного периода
  • Доимпорт параметров ЛС - обновление параметров лицевых счетов: перезапись или изменение с заданного периода
  • Переимпорт сальдо услуг
  • Область видимости - добавить/редактировать Области видимости для пользователей Агента (см. Пользователи. Группы объектов)
  • Внешние хранилища файлов - ссылки на внешние хранилища файлов, размещаемых в системе пользователями
  • Источники внешних идентификаторов - источники внешних идентификаторов и их связи с разделами системы
  • Обнуление сальдо

См.также

Импорт данных

Интерфейс разделов «Импорт» / «Сервис»

Раздел главного меню: «Импорт» → вкладки импортируемых данных.

Раздел главного меню: «Сервис» → Импорт данных из XLSX.

Интерфейс разделов состоит из следующих блоков:

  • Параметры импорта – форма для выбора и ввода значений параметров импорта данных в Систему (см. (1) – Рисунок «Интерфейс раздела «Импорт»», Рисунок «Интерфейс раздела «Сервис»») См. Заполнить параметры импорта в интерфейсе системы
  • Область отображения состояния очереди выполнения импорта (см. (2) - Рисунок «Интерфейс раздела «Импорт»», Рисунок «Интерфейс раздела «Сервис»»). Содержит информацию о состоянии очереди выполнения импорта загруженных файлов.
  • Список импортированных файлов (Журнал операций импорта) (см. (3) - Рисунок «Интерфейс раздела «Импорт»», Рисунок «Интерфейс раздела «Сервис»») предназначен для отображения результатов импорта по всем загруженным файлам. Далее по тексту «Журнал записей результатов импорта данных» или кратко «Журнал импорта».
../../_images/razdel_Import_interface.jpg

Интерфейс раздела «Импорт» (раздел главного меню: «Импорт» → вкладки импортируемых данных)

../../_images/razdel_Servic_interface.jpg

Интерфейс раздела «Сервис» (раздел главного меню: «Сервис» → Импорт данных из XLSX)

Шаги импорта данных

Импорт данных в разделе «Импорт» / «Сервис» состоит из следующих шагов:

  • Шаг 1. Выгрузить из системы файл-запрос (при отсутствии файла-запроса следует переходить к Шагу 2)
  • Шаг 2. Подготовить файл импорта:
  • Шаг 3. Заполнить параметры импорта в интерфейсе системы
  • Шаг 4. Импортировать файл
  • Шаг 5. Проверить результаты импорта
    • Отследить состояние очереди выполнения импорта
    • Импортированные файлы (Журнал операций импорта)

Примечание

Для получения актуальных шаблонов импорта отправьте заявку в Службу сопровождения.

Шаг 1. Выгрузить из системы файл-запрос

Выгрузите из Системы файл-запрос. При отсутствии файла-запроса следует переходить к следующему Шагу 2.

Файл-запрос формируется в подразделах главного меню «Сервис» при наличии соответствующей вкладки «Файл-запрос»:

../../_images/Import_fail-zapros.jpg

Формирование файла-запроса - пример рабочего окна

В Системе различают два вида файлов-запросов:

  • Файл-запрос стандарт – файл с заданной структурой, предназначенный для выгрузки из системы актуальных данных для последующего заполнения такого файла данными для импорта в систему. Пример: файл-запрос для импорта показаний ИПУ содержит актуальные данные по действующим ИПУ на лицевых счетах Агента, а также поля для ввода нового показания ИПУ.
  • Файл-запрос для экспорта в соцзащиту – файл с заданной структурой, содержащий информацию о предоставлении МСП отдельным категориям граждан. В отличие от стандартного файла-запроса, предназначен для импорта в систему актуальных данных о гражданах и льготах, предоставляется органом социальной защиты населения На основании данного файла-запроса из системы выгружается файл-ответ с данными о суммах начисления МСП.

К заполнению файла-запроса данными предъявляются требования, аналогичные требованиям для шаблонов импорта.

Примечание

Для получения описания полей файлов-запросов отправьте заявку в Службу сопровождения

Шаг 2. Подготовить файл импорта

Подготовить файл импорта по шаблону (в т.ч. заполнение файла-запроса)
  1. Заполните таблицу файла импорта данными в соответствии требованиям - см. раздел Требования к заполнению файла импорта по шаблону
  2. Подготовьте и сохраните файл в нужном формате:
Требования к заполнению файла импорта по шаблону
  • Обязательное наличие заголовков столбцов таблицы. Наименование заголовков столбцов таблицы зависит от выбранного шаблона импорта:
    • При выборе шаблонов, для которых на форме в интерфейсе поля не заполняются вручную, а только просматриваются по кнопке раскрытия списка полей Раскрыть параметры импорта - названия заголовков должны в точности совпадать с наименованиями полей на форме, открывающихся по кнопке Раскрыть параметры импорта.
    • При выборе шаблонов, для которых на форме в интерфейсе указываются только номера столбцов из таблицы файла импорта - названия заголовков могут быть произвольными.
  • Поля с красной заливкой, являются обязательными для заполнения. Если на момент импорта информация отсутствует, необходимо в любом случае указать один из предложенных вариантов. В дальнейшем допускается изменение параметров в системе, либо через процедуру до-импорта параметров.
  • Не допускается изменять структуру таблиц: добавлять и удалять столбцы, менять их наименование. Исключение - добавление и удаление строк.
  • Формат ячеек должен соответствовать формату данных, указанному в шаблоне: Числовой, Текст, Дата.
  • Особенности заполнения параметра «Дата» для периода действия услуг:
    • Для Агентов с действующим алгоритмом расчета [Начало действия услуги] = [С произвольной даты] период действия услуги задается произвольной датой календарного месяца (например, 16.03.2020)
    • Для остальных Агентов - период действия услуги задается с 01 числа периода подключения услуги по 01 число периода, следующего за периодом отключения услуги
  • Особенности заполнения параметров со значением = «0» («нулю»):
    • в столбцах с красной заливкой - обязательно к заполнению = «0» (число)
    • в столбцах с желтой заливкой - не обязательно к заполнению
  • Строка, отмеченная заливкой оранжевого цвета, приведена для примера. В итоговом файле такие строки требуется удалить.
  • Для файлов импорта объектов жилфонда:
    • Наименование одних и тех же улиц должно совпадать на вкладках «Дома» и «Счета»
    • Лицевые счета по нескольким населенным пунктам и домам необходимо вводить в одну таблицу на одном листе (вкладка «Счета»)
    • Дата начального сальдо ЛС должна соответствовать дате начала ведения ЛС в системе
    • Коды и наименования населенных пунктов и улиц должны соответствовать КЛАДР:
      • Правильно: «ул Карла Маркса», «пр-кт»
      • Неправильно: «ул.К.Маркса», «пр-т»

Примечание

Для получения актуальных шаблонов импорта отправьте заявку в Службу сопровождения.

Внимание

«ФНС России сообщает:
выгрузка адресных сведений в формате ведомственного классификатора адресов (далее – КЛАДР) версии 4.0 будет осуществляться до 31.12.2017г.
После 31.12.2017г сведения из государственного адресного реестра (далее – ГАР) будут выгружаться только в формате федеральной информационной адресной системы (далее – ФИАС).»
Источник: https://fias.nalog.ru/NewsViewPage.aspx?id=10020
Следите за нововведениями системы в разделе Что нового?

Подготовить и сохранить файл импорта в формате DBF

Примечание

  1. Инструкция подготовлена на примере приложения OpenOffice.
  2. Приложения MS Excel 2007(2010) сохранение файла в формате DBF не поддерживают.
  3. Для получения актуальных шаблонов импорта отправьте заявку в Службу сопровождения.
  1. Откройте файл-шаблон в приложении OpenOffice.
  2. Заполните таблицу выбранного шаблона данными – см. Требования к заполнению файла импорта по шаблону.
  3. Укажите формат ячеек для каждого столбца в соответствии с требованиями выбранного шаблона:
  • Щелкните правой кнопкой мыши в заголовке выбранного столбца (колонки)
  • В появившемся контекстном меню выберите пункт «Формат ячеек…»
  • В диалоговом окне укажите требуемый формат: «Числовой», «Текст», «Дата» и т.п.
  • Для формата «Числовой» укажите параметр «Дробная часть» (при наличии дробных значений)
  1. Сохраните файл в формате DBF:
  • Выберите пункт главного меню: Файл ‣ Сохранить как…
  • Укажите параметры:
    • Путь к папке на ПК, в которую требуется поместить файл
    • Имя файла - произвольное название файла
    • Тип файла - dBASE (.dbf)
  • Подтвердите выбор формата - нажмите кнопку Использовать текущий формат:
../../_images/DBF_ispolzovat-tek-format_okno.jpg
  • Укажите кодировку: Кириллица (DOS/OS2-866/русский) и нажмите кнопку «ОК»
../../_images/DBF_export-DBase-okno.jpg
  1. Файл сохранен в формате DBF
  2. Проверьте значения и формат данных в сохраненном файле:
  • Откройте файл в приложении OpenOffice
  • Проверьте, все ли данные конвертировались верно: например, все ли цифры имеются в номере лицевого счета, правильно ли отображена дата, присутствуют ли дробные части в суммах и т.п.
  • При неоходимости измените значения и формат данных и повторно сохраните файл - см. п.4
  1. Файл готов к импорту в систему - см. Шаг 4. Импортировать файл
Подготовить и сохранить файл импорта в формате CSV

Примечание

  1. Инструкция подготовлена на примере приложения OpenOffice.
  2. Сохранение файлов в формате CSV поддерживается приложениями MS Excel 2007(2010), OpenOffice.
  3. Для получения актуальных шаблонов импорта отправьте заявку в Службу сопровождения.
  1. Откройте файл-шаблон в приложении OpenOffice.
  2. Заполните таблицу выбранного шаблона данными – см. Требования к заполнению файла импорта по шаблону.
  3. Укажите формат ячеек для каждого столбца в соответствии с требованиями выбранного шаблона:
  • Щелкните правой кнопкой мыши в заголовке выбранного столбца (колонки)
  • В появившемся контекстном меню выберите пункт «Формат ячеек…»
  • В диалоговом окне укажите требуемый формат: «Числовой», «Текст», «Дата» и т.п.
  • Для формата «Числовой» укажите параметр «Дробная часть» (при наличии дробных значений)
  1. Сохраните файл в формате CSV:
  • Выберите пункт главного меню: Файл ‣ Сохранить как…
  • Укажите параметры:
    • Путь к папке на ПК, в которую требуется поместить файл
    • Имя файла - произвольное название файла
    • Тип файла - Текст CSV (.csv) (в MS Excel 2007(2010) Тип файла - «CSV (разделители - запятые)»)
  • Подтвердите выбор формата - нажмите кнопку Использовать текущий формат CSV:
../../_images/CSV_ispolzovat-tek-format_okno.png
  • Укажите кодировку:
    • Кириллица (DOS/OS2-866/русский)
    • Разделитель полей ,
    • Разделитель текста «
  • Нажмите кнопку «ОК»
../../_images/CSV_export-DBase-okno.png
  1. Файл сохранен в формате CSV
  2. Файл готов к импорту в систему - см. Шаг 4. Импортировать файл
Требования к файлам импорта произвольной структуры
  • Таблица в файле должна содержать поля, обязательные для импорта - в рабочем окне импорта отмечены знаком (*).
  • Первая строка таблицы должна содержать наименование столбцов, допускается использование латинских букв.
  • Требования к названию файла и формату данных при его сохранении:
    • Название файла: цифры и/или латинские буквы, произвольный текст
    • Форматы файлов: CSV, XLSX, DBF
    • При сохранении файла в форматах CSV и DBF следует подтвердить использование формата dBASE и задать кодировку «Юникод (UTF-8)»
  • Для файла DBF ОБЯЗАТЕЛЬНО требуется настроить формат данных и максимальную длину (количество символов) поля:
Формат данных в файлах импорта DBF (на примере файла «Импорта поступлений»)
Раздел импорта Наименование поля Формат данных Кол-во
символов

Импорт

поступлений

Лицевой счет Текстовый 20
Сумма платежа Числовой 10,2
Дата платежа Дата (ДД.ММ.ГГГГ) 10
Префикс принципала Текст 10
ID транзакции Текст 50
Тип операции Текст 20
ID услуги ЛС Текст 20
Место приема платежа Текст 150
Примечание Текст 224
Регистратор Текст 25
Тип платежа Текст 50

Шаг 3. Заполнить параметры импорта в интерфейсе системы (режимы «Импорт файла» / «Импорт с формы»)

  1. Перейдите в соответствующий раздел главного меню Импорт → вкладка [Тип импортируемых данных].
  2. Заполните параметры импорта в интерфейсе системы:
  • «Действие» - выбор действия для операции импорта:
    • Импорт - импорт данных в систему
    • Обновление - обновление/замена существующих в системе данных на данные из файла импорта
    • Удаление - удаление ошибочно импортированных данных из системы
  • «Параметры файла» - выбор режима импорта:
    • Импорт файла – импорт данных с помощью подготовленного файла данных
    • Импорт с формы – импорт одной записи
  • «Импорт [тип импортируемых данных]» - выбор шаблона импорта (примеры шаблонов: «Базовый», «Базовый по Номеру ЛС» и т.д., зависит от типа импортируемых данных)
  • Импортируемые параметры, в зависимости от выбранного режима импорта:
    • При выбранном режиме «Импорт файла» предусмотрено два варианта определения импортируемых данных (зависит от типа импортируемых данных и выбранного шаблона):
      • «Укажите значение полей» - ввод данных в поля параметров импорта.
      • «Раскрыть параметры импорта Поля выбранного шаблона» - раскрытие списка полей шаблона импорта данных для просмотра (без возможности редактирования).
    • При выбранном режиме «Импорт с формы» предусмотрена возможность ввода данных импорта:
      • «Параметры импорта» – ввод/выбор значений импортируемых параметров (состав параметров импорта зависит от типа импортируемых данных и выбранного шаблона).
При выбранном режиме «Импорт файла»: При выбранном режиме «Импорт с формы»:
1. Если выводится название заголовка группы
параметров «Укажите значение полей», следует
заполнить значения в поля параметров импорта:

a. Колонка «Номер поля» предназначена для ввода
порядкового номера положения соответствующего
параметра в структуре файла данных. Например, поле
в интерфейсе «Номер договора» = колонка/столбец
из файла импорта № 1; «Дата платежа» = 2;
«Сумма платежа» = 3 и т.д.

b. Колонка «Значение» – для ввода/выбора значения
конкретного параметра, единого для всех записей
в импортируемом файле. Например, для импорта
поступлений, при отсутствии в файле поля с датой
платежа и при заданном значении поля
«Дата платежа» = 01.03.2020, для всех
импортированных в систему записей дата платежа
будетустановлена 01.03.2020.

Укажите значение параметров

Для каждого параметра допускается ввод одного
значения – только в одной из колонок
– либо «Номер поля», либо «Значение».

2. Если выводится название заголовка группы
параметров «Раскрыть параметры импорта Поля выбранного шаблона», то есть
возможность просмотреть список импортируемых
параметров:
Раскрыть параметры импорта/Свернуть параметры импорта - кнопка развернуть/свернуть предназначена
для просмотра перечня полей выбранного
шаблона (доступны только для просмотра.

Раскрыть параметры файла импорта

Свернуть параметры файла импорта
В группе параметров под заголовком «Параметры
импорта» следует ввести/выбрать значения
в импортируемых полях параметров:

Импорт с формы параметров
   

Примечание

Настройки формы «Параметры файла», сделанные один раз пользователем – сохраняются. При следующем проведении импорта, параметры введенные ранее, будут автоматически заполнены.

Шаг 4. Импортировать файл

Импорт. Режим «Импорт файла»
  1. После заполнения необходимых параметров импорта (см. раздел Шаг 3. Заполнить параметры импорта в интерфейсе системы (режимы «Импорт файла» / «Импорт с формы»)), перейдите к выполнению импорта в соответствующем разделе:
    • «Импорт» - для импорта данных в систему из файлов произвольной структуры или единичного импорта введенных значений из заполненной формы в интерфейсе
    • «Сервис» - для импорта файла по шаблону установленного образца
  2. Нажмите кнопку Выбрать файлы и в открывшемся окне выберите нужный файл/файлы для импорта (для выбора нескольких файлов, удерживайте клавишу «Ctrl»).
  3. Нажмите кнопку Принять или Импорт (в зависимости от выбранного раздела).
  4. В случае успешной проверки, файл с данными помещается в очередь на импорт. В блоке «Очередь выполнения» появляется запись о состоянии импорта.
  5. Если проверка завершится ошибкой, то система выведет на экран сообщение об ошибке и перейдет в состояние импорта – «ДО выбора файла». Для повторной передачи данных импорта, необходимо исправить ошибки, при необходимости загрузить файл импорта, и вновь нажать кнопку Принять.
Импорт. Режим «Импорт с формы»

Для режима «Импорт с формы» выбор файла не требуется.

  1. После ввода значений параметров импорта на форме нажмите кнопку Принять.
  2. После нажатия кнопки Принять происходит первичная проверка значений параметров для импорта:
    • В случае успешной проверки Система создает файл с данными в формате csv и помещает этот файл в очередь на импорт.
    • Если проверка завершится с ошибкой, система выведет на экран сообщение об ошибке и перейдет в предыдущее состояние, до нажатия кнопки Принять.

Шаг 5. Проверить результаты импорта

Разделы для просмотра результатов импорта:

См.также

Инструкции: Ошибки импорта данных

Очередь выполнения импорта

Блок «Очередь выполнения» содержит информацию о состоянии очереди выполнения импорта загруженных файлов.

После заполнения параметров импорта и нажатия кнопки «Принять»/ «Импорт», Система выполняет проверку загружаемых данных. В результате успешной проверки файл(ы) с данными помещаются в очередь на импорт, запись об этом появляется в блоке «Очередь выполнения».

../../_images/Ochered_fail_ocheredi.jpg

Очередь выполнения импорта - статус Импортируется

Для обновления страницы (обновление информации о состоянии очереди импорта) используйте кнопку «Обновить» Обновление.

../../_images/Obnovlenie_statusa_importa.png

Кнопка для обновления страницы в процессе импорта

После завершения импорта запись об импортируемом файле исчезнет из списка «Очередь выполнения» (время выполнения зависит от размера загружаемого файла и наличия других заданий в очереди). А в блоке «Импортированные файлы» появится запись об импортированном файле с информацией о результатах импорта.

../../_images/Zaverch_fail_ocheredi.png

Очередь выполнения импорта – Импорт завершен

Примечание

Время выполнения операции импорта может варьироваться от нескольких секунд (количество записей в файле– 100, количество импортируемых полей – 6), до 40 минут – (количество записей в файле 100 000, количество импортируемых полей – 10).

См.также

Инструкции: Ошибки импорта данных

Импортированные файлы (Журнал операций импорта)

Блок «Импортированные файлы» предназначен для отображения результатов импорта по всем загруженным файлам и представляет собой «Журнал результатов импорта данных» (далее «Журнал импорта»).

../../_images/Zhurnal_importa_dannykh.jpg

Журнал импорта (на примере импорта поступлений)

Параметры таблицы «Журнала импорта»:
  • № – порядковый номер записи
  • ID импорта – идентификационный номер записи импортированного файла данных (присваивается Системой)
  • Параметры – отображение списка параметров импорта, для которых были введены данные на форме ввода значений параметров. Ссылки Развернуть (раскрыть) и Свернуть (свернуть).
../../_images/Otobrazhenie-skrytie_parametrov.png

Отображение/скрытие перечня параметров (на примере импорта поступлений)

  • Пользователь – ФИО пользователя, который импортировал файл
  • Имя файла – исходный файл импорта (к имени файла добавлены дата и время импорта данных в систему). Доступен для выгрузки.
  • Статус – статус импорта:
    • Выполнен – импорт завершен успешно
    • Удален – импортированный файл удален из Системы
    • Ошибка – сбой при импорте файла в Системе
  • Всего/ошибочных – отображает количество записей в файле и количество не импортированных в систему записей. Например, запись 44/1 означает что из 44 записей в файле 43 записи содержат корректные данные и одна – некорректные.

Примечание

По результатам импорта данных создается два файла – «Файл ошибок» и «Файл логов».
Ссылка на первый файл размещается в поле «Всего/ошибочных» и содержит информацию о причине ошибки импорта по каждой ошибочной записи.
Ссылка на второй файл помещается в поле «Лог» и содержит информацию о всех успешно импортированных в систему данных с кратким комментарием результата операции импорта.

  • Лог – лог-файл успешно импортированных записей
  • Время создания/окончания – время импорта
  • Шаблон – шаблон импорта
  • Действие – наименование операции с файлом (импорт информации из файла в Систему или удаление информации из Системы)
Действия в таблице «Журнала импорта»:
  • Значок Просмотр – предназначен для просмотра детализации всех импортированных записей и записей, в которых допущены ошибки
  • Значок +Удаление записи - удаление импортированных данных
  • Ссылка «Файл логов» - ссылка на файл логов помещается в колонке «Лог» и содержит информацию о всех успешно импортированных в систему данных с кратким комментарием результата операции импорта. Появляется в результате импорта данных.
  • Ссылка «Файл ошибок» - ссылка на файл ошибок размещается в колонке «Всего/ошибочных» и содержит информацию о причине ошибки импорта по каждой ошибочной записи. Появляется в результате импорта данных в случае наличия ошибочных записей.
../../_images/Prosmotr_oshibochnykh_zapisei.png

Способы просмотра детализации результатов импорта (на примере импорта поступлений)

../../_images/Detalizatciia_importa.png

Детализация импортированных записей с помощью значка Просмотр

../../_images/Fail_oshibochnykh_zapisei.png

Файл ошибочных записей

Удаление / Обновление импортированных данных через действие «Удалить / Обновить»

Действия импорта «Удаление» / «Обновление» предназначены для удаления или обновления существующих данных из/в Системе. Для выполнения этих действий, необходимо заранее подготовить файл импорта с данными, которые требуется удалить или обновить.

Порядок действий при удалении/обновлении данных из/в Системе полностью совпадает с порядком действий при импорте добавления данных в Систему.

../../_images/Obnovlenie_Udalenie_import.jpg

Действия импорта

  1. Подготовьте файл с данными, по которым необходимо выполнить удаление/обновление (в соответствии требованиям раздела Шаг 2. Подготовить файл импорта)
  2. Введите необходимые значения параметров обновления/удаления в интерфейсе системы (Шаг 3. Заполнить параметры импорта в интерфейсе системы (режимы «Импорт файла» / «Импорт с формы»))
    • Для удаления данных: Параметр «Действие» = «Удаление»
    • Для обновления данных: Параметр «Действие» = «Обновление»
  3. Произведите обновление или удаление данных (Шаг 4. Импортировать файл)
  4. Проконтролируйте очередь выполнения операции обновления/удаления.
  5. Проверьте результаты импорта.

В результате, в блоке «Импортированные файлы» в поле «Действие» для соответствующей операции будет выведено значение «Удаление / Обновление».

../../_images/Gurnal_import_udalenie.jpg

Журнал импорта с записями об удалении данных

Удаление импортированного файла по значку Удалить

Для удаления ошибочно импортированного файла данных применяется значок Удалить, расположенный в блоке «Импортированные файлы» (Журнал импорта).

../../_images/Udalenie_importa_krestik.jpg

Журнал импорта – значок для удаления импортированной записи

В этом случае происходит удаление импортированного файла со значениями параметров. Для корректности работы рекомендуется использовать этот инструмент удаления в текущем открытом периоде для ошибочно импортированных файлов.

В результате удаления, статус в колонке «Статус» для выбранной записи изменится с «Выполнен» на «Удален».

Перечень возможных ошибок импорта данных

Перечень ошибок импорта данных в интерфейсе

Пример ошибки №1

Пояснение ошибки: Не заполнено обязательное поле.

../../_images/Oshibka_zapoln_pole.jpg

Ошибка «Необходимо заполнить поле…»

Исправление ошибки:

  1. Заполните поле недостающим значением.
  2. При выбранном режиме «Импорт файла», повторно выберите файл для импорта.
  3. Нажмите кнопку «Принять».

Пример ошибки №2

Пояснение ошибки: Для одного параметра заполнены два поля из двух - и «Номер поля», и «Значение». Требуется заполнить только одно поле из двух.

../../_images/Oshibka_zapolnit_odno_pole.jpg

Ошибка «Заполните только одно из полей»

Исправление ошибки:

  1. Оставьте заполненным только одно из двух полей для данного параметра.
  2. При выбранном режиме «Импорт файла», повторно выберите файл для импорта.
  3. Нажмите кнопку «Принять».

Пример ошибки №3

Пояснение ошибки: После заполнения параметров импорта на форме интерфейса при режиме «Импорт файла» не выбран файл импорта.

../../_images/Oshibka_vibrat_fail.jpg

Ошибка «Необходимо выбрать файл»

Исправление ошибки:

  1. Нажмите кнопку «Выбрать файлы» и выберите файл/файлы с данными для импорта (для выбора нескольких файлов, удерживайте клавишу «Ctrl»).
  2. Нажмите кнопку «Принять».

Пример ошибки №4

Пояснение ошибки: Формат выбранного файла не поддерживается Системой, и отличается от разрешенных к импорту форматов (dbf, csv, xls, xlsx).

../../_images/Oshibka_format_ned.jpg

Ошибка «Недопустимый формат файла»

Исправление ошибки:

  1. Пересохраните выбранный ранее файл в нужном формате: xls, xlsx, csv или dbf.
  2. Повторно произведите операцию выбора файла для импорта.
  3. Нажмите кнопку «Принять».

ИЛИ

  1. Нажмите кнопку «Выбрать файлы» и выберите файл/файлы формата xls, xlsx, csv или dbf (для выбора нескольких файлов, удерживайте клавишу «Ctrl»).
  2. Нажмите кнопку «Принять».

Пример ошибки №5

Пояснение ошибки: Указанный номер столбца/колонки таблицы файла импорта на форме в интерфейсе не соответствует количеству столбцов/колонок в файле.

../../_images/Oshibka_Nomer_kolonki_ne_sovpadaet.jpg

Ошибка из-за несоответствия номера столбца/колонки и количеству столбцов в файле импорта

Исправление ошибки:

  1. Введите корректное значение номера столбца/колонки.
  2. Повторно выберите файл для импорта.
  3. Нажмите кнопку «Принять».
Перечень возможных ошибок в импортируемом файле данных

Если в результате импорта формируется Файл ошибочных записей в блоке «Импортированные файлы», значит, имеются записи, которые не были загружены в Систему из-за наличия ошибки. Ссылка «Файл ошибок» размещается в колонке «Всего/ошибочных» и содержит информацию о причине ошибки импорта по каждой ошибочной записи.

Ошибки могут быть разные, в зависимости от типа импортируемых данных.

Исправление ошибки:

  1. Необходимо посмотреть описание ошибки в файле ошибочных записей.
  2. Исправить ошибку.
  3. Повторно импортировать данные.

См.также

Инструкции: Ошибки импорта данных

Настройка параметров импорта

Параметры импорта содержат данные системных справочников в виде списка значений для выбора.

Справочные данные, зайдействованные в качестве параметров импорта
Раздел импорта Параметр Раздел интерфейса
(ссылка на Руководство)
Импорт поступлений
Обмен с банками
Организация Справочники ‣ Служебные ‣ Платежи ‣
Организации по приему платежей
(Организации по приему платежей)
Тип платежей Справочники ‣ Служебные ‣ Платежи ‣
Типы платежей
(Типы платежей)
Принципал Справочники ‣ Субъекты ЖКХ ‣ Принципалы
(Справочник «Принципалы»)
Экспорт в соц.защиту Группировка по
идентификатору
соцзащиты
Справочники ‣ Услуги ‣ Перечень
(Справочник «Перечень (услуг)»)
Импорт данных из XLSX:    
Показания ПУ Тип показания Справочники ‣ Служебные ‣ ПУ ‣
Параметры учета показаний ‣ Типы показаний
(Типы показаний)
Импорт ИПУ Место установки ИПУ Справочники ‣ Служебные ‣ ПУ ‣
Места установки ПУ
(Места установки ПУ)

Экспорт данных

Экспорт данных производится в виде файлов установленной структуры с целью последующей загрузки таких файлов во внешние информационные системы (1С:Бухгалтерия, банки, органы соцзащиты и др.)

Как правило, экспорт данных из системы производится с применением архивирования в формате ZIP.

Совет

  1. Для получения информации об актуальных шаблонах экспорта данных отправьте заявку в Службу сопровождения
  2. Для разработки/подключения нового шаблона экспорта данных обратитесь в Службу сопровождения

См.также

Руководство: Отчеты